Windows Phone 8.1 APPX Code Signing Weird Error When Installing

Windows Phone 8.1 APPX Code Signing Weird Error When Installing

Over the last couple of days I’ve been trying to diagnose what we were doing wrong when code signing a Windows Phone 8.1 APPX file in preparation for enterprise distribution. The signing process completes successfully. However, when we go to install the application on either device or emulator we were seeing weird errors (see image below that quotes an exception code of 0x80073CF9).

clip_image002

SOLVED: It turns out that there is an issue with the signing process but nothing related to what we were doing. It’s actually related to the version of the tools we’re using. Here’s a list of the toolsets that apparently work/don’t work:

Visual Studio 2013 with Update 2 RC – WORKS
Visual Studio 2013 with Update 2 RTM – DOESN’T WORK
Visual Studio 2013 with Update 3 RC – WORKS

So you either need to regress to the RC of Update 2, or go to the RC of Update 3.

Side Note: If you see errors relating to a missing token, you’re probably attempting to install the package by calling AddPackageAsync from within an application that isn’t signed (ie a developer build pushed out using either the application deployment tool, or via Visual Studio). If you sign the application doing the installation and then install it, you should see the the call to AddPackageAsync will work for correctly signed XAP and APPX. This is a breaking change from Windows Phone 8.0 where this method worked regardless of whether the installer app was signed or not.