Where’d My Applications Go, A Windows Mobile Marketplace Mystery

Where’d My Applications Go, A Windows Mobile Marketplace Mystery

This morning I was looking for update to the WWOS Cricket widget which NineMSN published late last year. I had already “purchased” (it’s a free app, so it’s not really purchasing) the widget so I was surprised that it was not listed under My Applications within the Marketplace application on the device. Being a little confused by this I thought it may be specific to my device so I loaded up one of the emulators and again, no applications to install.

After a bit of thinking (actually I went off and did other things) it came to me that it may be to do with the region I have my device set to.  For whatever reason when I rebuilt my device last I had forgotten to set the region back to Australia.  Similarly, the default region for the emulators is also the US, which is why neither the device or emulator was showing my applications. Sure enough, when I reset my region back to Australia, which requires a reboot, I could again see my applications.

In my opinion this is just confusing – if I’ve bought an application/widget and I’ve signed into Marketplace I should see all the applications/widgets I’ve purchased, regardless of which region my device is currently set to.

For those not familiar with the Marketplace application or haven’t seen the WWOS Cricket widget, here’s a few images to get you started.

 image image 

image image

Leave a Reply

Your email address will not be published. Required fields are marked *